В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
vashchilkophoto
vashchilkophoto
04.09.2020 05:39 •  Информатика

На PYTHON Напишите программу, которая выводит на экран рисунок из 40
колец разных цветов (не менее 8 случайных цветов). (Подсказка:
при решении необходимо двигаться от внешнего круга к
внутреннему)

Показать ответ
Ответ:
yadianamelnik
yadianamelnik
27.02.2022 19:15

Для начала нужно выбрать игровой движок.

Так как ты не шаришь, то можно выбрать какой-нибудь game-maker, он прост. Конечно же, у тебя на этом движке не выйдет нормальных игр, но для того, чтобы понять все это - сойдет.

Какие языки нужно знать?

Смотря какой движок, если Unity, то C#.

Почитай в интернете о игровых движках.

Как учить?

Самое главное в изучении языков - практика. Прочитал что-то новое, идешь сразу пробовать, иначе не поймешь нормально. Лично я учил и учу языки по книгам и видеоурокам от иностранных ютуберов (Русские хуже объясняют, поверь).

0,0(0 оценок)
Ответ:
Mildx
Mildx
08.08.2020 20:37

#arr = [*map(int, input().split(' 0')[0].split())]  если числа вводятся в строчку , то раскомментируйте и используйте эту строку, а инициализацию массива arr и цикл while закомментируйте

arr = []

while 1:

   tmp = int(input())

   if tmp != 0:  # Читаем сколько угодно чисел пока не будет ноль

       arr.append(tmp)

   else:

       break

s = 0  # сумма двузначных чисел

k = 0  # количество двузначных чисел

for i in arr:

   if 10 <= i <= 99:  # итерируемся по циклу и если число двузначное

       s += i  # то прибавляем его к сумме

       k += 1  # счетчик двузначный чисел увеличиваем на один

print(s/k) if k > 0 else print('NO') #если количество двузначных > 0 то выводим среднее арифметическое s/k, если нет то выводим NO

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота