В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
medi8
medi8
05.08.2022 16:42 •  Информатика

На PYTHON. Напишите программу, подсчитывающую во введенной строке количество гласных

букв.​

Показать ответ
Ответ:
Nactyxa2003
Nactyxa2003
16.07.2022 22:51

N = int(input('Введите N (строки): '))

M = int(input('Введите M (столбцы): '))

array_1 = []

array_2 = []

array_3 = []

el = 0

for i in range(N):

   a = []

   if M % 2 == 0 and i > 0:

       if el == 0:

           el = 1

       else:

           el = 0

   for _ in range(M):

       a.append(el)

       if el == 0:

           el = 1

       else:

           el = 0

   array_1.append(a)

print('Задание 1.')

for row in array_1:

   for el in row:

       print(el, end = ' ')

   print()

for i in range(N):

   a = []

   for j in range(N):

       if j > i:

           a.append(0)

       else:

           a.append(1)

   array_2.append(a)

print()

print('Задание 2.')

for row in array_2:

   for el in row:

       print(el, end = ' ')

   print()

           

for i in range(N):

   a = []

   for j in range(N):

       if j < N - i - 1:

           a.append(0)

       else:

           a.append(1)

   array_3.append(a)

print()

print('Задание 3.')

for row in array_3:

   for el in row:

       print(el, end = ' ')

   print()

0,0(0 оценок)
Ответ:
muzaka
muzaka
17.02.2022 04:57

Объяснение:

Мо́ва програмува́ння (англ. Programming language) — це штучна мова, створена для передачі команд машинам, зокрема комп'ютерам. Мови програмування використовуються для створення програм, котрі контролюють поведінку машин, та запису алгоритмів.

Більш строге визначення: мова програмування — це система позначень для опису алгоритмів та структур даних[1], певна штучна формальна система, засобами якої можна виражати алгоритми[2]. Мову програмування визначає набір лексичних, синтаксичних і семантичних правил, що задають зовнішній вигляд програми і дії, які виконує виконавець (комп'ютер) під її управлінням.[джерело?]

З часу створення перших програмованих машин було створено понад дві з половиною тисячі мов програмування.[3] Щороку їх кількість поповнюється новими. Деякими мовами вміє користуватись тільки невелике число їх власних розробників, інші стають відомі мільйонам людей. Професійні програмісти зазвичай застосовують у своїй роботі декілька мов програмування.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота