В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sek071001p0ancj
sek071001p0ancj
25.07.2022 10:06 •  Информатика

На Python нужно сделать: "Напишите программу, которая получает с клавиатуры трёхзначное число.
В результате работы программа выводит на экран все числа (каждое на новой
строке), которые получены в результате перестановки цифр исходного числа."

Показать ответ
Ответ:
незнайка2901
незнайка2901
01.11.2020 16:48

§1.  о системах счисления.

  n4. развернутая форма записи числа

 

из курса вам известно, что цифры десятичной записи числа – это просто коэффициенты его представления в виде суммы степеней числа – основания системы счисления:

       

      25076 = 2*10000 + 5*1000 + 0*100 + 7*10 + 6*1 = 2*104  +5*103  + 0*102  +7*101+6*100

 

при переводе чисел из десятичной системы счисления в римскую мы и воспользовались этим правилом (444 = 400 + 40 + 4;   2986 = 2000 + 900 + 80 + 6).

при записи чисел значение каждой цифры зависит от ее положения. место для цифры в числе называется разрядом, а количество цифр в числе разрядностью. на самом деле числа можно записывать как сумму степеней не только числа 10, но и любого другого натурального числа, большего 1.

 

определение.  развернутой формой записи числа называется такая запись: а4а3а2а1а0  = а4*q4  + a3*q3  + a2*q2  + a1*q1  + a0*q0  , где а4,а3,а2,а1,а0  –цифры числа, q –основание степени.

 

 

пример1.  получить развернутую форму числа 7512410.

решение:

  а4  = 7, а3  = 5, а2  =1 ,а1  =2, а0  =4,          q=10

 

4 3 2 1 0

75 12410  = 7*104  + 5*103  + 1*102  + 2*101  + 4*100.

 

 

пример2.  получить развернутую форму числа 1123.

решение:

 

2 1 0

1123  = 1*32  + 1*31  +2*30

 

пример3.  получить развернутую  форму числа  176,218.

решение:                     21 0-1-2а8=176, 218=1*82+7*81+6*80+2*8-1+1*8-2  для самостоятельной работы: 1. запишите в развернутом виде числа: а8=143511,62а2=100111а10=143,511а16=1а3,5с12. запишите в свернутой форме число: 9*101+1*100+5*10-1+3*10-2a*162+1*161+c*160+3*16-1
0,0(0 оценок)
Ответ:
Dogi2008
Dogi2008
27.02.2023 16:00
Const   n = 50; // количество чиселvar   k: array [1..n] of integer;   i, j, n1, n2, minr, a, b: integer; begin   writeln(n, ' ', ': d');   a : = random(1000);   b : = random(1000);   minr : = 10000;   for i : = 1 to n do       k[i] : = a + random(b);   for i : = 1 to n do       for j : = 1 to n do           if ((abs(k[i] - k[j])) < minr) and (k[i] < > k[j]) then           begin               minr : = abs(k[i] - k[j]);               n1 : = i;               n2 : = j;           end;   writeln(n1, ' ', n2); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота