В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Сutie2004
Сutie2004
02.03.2020 08:24 •  Информатика

На PYTHON Описать функцию Fib(N), вычисляющую N-й элемент
последовательности чисел Фибоначчи F K , которая описывается
следующими формулами:
F 1 = 1, F 2 = 1, F K = F K−2 + F K−1 , K = 3, 4, … .
Используя функцию Fib, найти пять чисел Фибоначчи с данными
номерами N 1 , N 2 , …, N 5 . Вывод результата должен выполняться в
ОСНОВНОЙ программе!!

Показать ответ
Ответ:
666Default666
666Default666
12.10.2022 21:34

При определении значений подобных функций переменная y вычисляется по-разному (по разным формулам) в зависимости от значения x.

Такие задачи решаются с конструкции условного оператора if - else. Поскольку в данном случае мы имеем три условия (x > 0, x = 0 и x < 0), то потребуется использование еще вложенной конструкции if - else, т. к. в языке Pascal нет оператора множественного ветвления (оператор case в данном случае не подходит).

В языке программирования Паскаль (да и в других тоже) желательно вложенные конструкции if - else помещать во внешнюю ветку else, а не if. Так проще не запутаться.

Таким образом, алгоритм вычисления значения функции может быть таким:

Если x > 0, то у = x - 2

Иначе (ниже идет вложенная конструкция)

Если x = 0, то y = 0

Иначе y = |x|.

В последнем пункте можно опустить оператор if с проверкой, что x < 0, так как если ход выполнения программы дошел до этого пункта, то x уже другим быть и не может (варианты, когда он больше или равен нулю, уже были исключены).

Для определения модуля (абсолютного значения) переменной можно использовать встроенную функцию abs() языка Pascal. В данном случае можно обойтись и без нее: поскольку уже известно, что x отрицателен, то, чтобы получить положительное число (модуль), нужно его умножить на -1.

var

   x, y: integer;

 

begin

   write ('x = ');

   readln (x);

 

   if x > 0 then

       y := x - 2

   else

       if x = 0 then

           y := 0

       else

           y := abs(x);

 

   writeln ('y = ', y);

 

end.

Объяснение:

0,0(0 оценок)
Ответ:
jddosnfkdmsns
jddosnfkdmsns
10.01.2021 05:44
Число DCXLI, записанное римскими цифрами, в десятичной системе счисления соответствует числу:
D = 500, С = 100, XL = L - X = 50 - 10 = 40, I = 1
DCXLI = 500 + 100 + 40 + 1 = 641
 
Выберите те числа, в которых есть ошибка:
1902,25 (8) — ошибка, в восьмеричной системе нет цифры 9
12,21 (3) — ок
A6,4 (12) — ок, A = 10
99,99 (9) — ошибка, в девятеричной системе нет цифры 9
 
Алфавит восьмеричной системы счисления записывается так:
{0,1,2,…,7} — для n-ичной системы счисления это цифры от 0 до n - 1.
 
Последовательность знаков числа 11011 (2) в десятичной системе счисления соответствует числу: 
2^4 + 2^3 + 2^1 + 2^0 = 16 + 8 + 2 + 1 = 27 (10)
 
Переведите число 207 (8) в десятичную систему счисления.
207 (8) = 2 * 8^2 + 0 * 8^1 + 7 * 8^0 = 128 + 0 + 7 = 135 (10)
 
Переведите число 18 (10) в двоичную систему счисления.
18 (10) = 16 + 2 = 1 * 2^4 + 0 * 2^3 + 0 * 2^2 + 1 * 2^1 + 0 * 2^0 = 10010 (2)
 
Переведите число 75 (10) в шестнадцатеричную систему счисления.
75 (10) = 4 * 16 + 11 = 4B (16)
 
Греются на солнышке воробьи. На нижней ветке их было 110 (2), на верхней – на 2 (10) меньше. Сколько всего было воробьев?
110 (2) = 2^2 + 2^1 = 5 — на первой ветке
5 - 2 = 3 — на второй ветке
5 + 3 = 8 — всего
 
Укажите основание х системы счисления, если известно, что 29 (10) = 38 (х).
38 (x) = 3 * x + 8 = 29 (10)
3x + 8 = 29
3x = 21
x = 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота