В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
maxidro1
maxidro1
13.06.2021 09:07 •  Информатика

На Python
Самое частое число
Дан список. Не изменяя его и не используя дополнительные списки, определите, какое число в этом списке встречается чаще всего.

Если таких чисел несколько, выведите любое из них.

Входные данные

Вводится список чисел. Все числа списка целые, по модулю не превосходят 1000 и находятся на одной строке.

Выходные данные

Выведите ответ на задачу.

Примеры
Ввод
Вывод
1 1 1 1 2 2 2 3 3 3
1

Показать ответ
Ответ:
samyi116umni
samyi116umni
15.10.2020 03:20

lst = [int(_) for _ in input().split()]

dictionary = dict()

for num in lst:

   if num in dictionary:

       dictionary[num] += 1

   else:

       dictionary[num] = 1

print(max(dictionary.items(), key=lambda x: x[1])[0])

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота