В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Roserum
Roserum
19.03.2020 17:51 •  Информатика

НА Python У вас есть с собой T (T вводится с клавиатуры) золотых монет.

Местные жители согласились продать вам припасы, но у них есть странный ритуал. Всего в деревне n (n вводится с клавиатуры) жителей, у каждого из них цена за килограмм припасов составляет определенное количество монет (число монет для каждого жителя вводится с клавиатуры и собирается в список).

Вы должны покупать припасы следующим образом:

Сначала покупаете 1 кг у первого жителя, потом идете ко второму, независимо от того, хватило ли денег, потом идете к третьему, и т.д. Как только обойдете всех жителей, идете снова к первому, потом ко второму и т.д.

Напишите программу, которая определит, сколько всего кг припасов вы можете купить по такому принципу.

Оптимизируйте программу, максимально снизив количество итераций в цикле

Показать ответ
Ответ:
098473
098473
12.02.2021 22:42

T = int(input())

lst = [int(input()) for i in range(int(input()))]

t1, kg = 0,0

while True:

   for i in lst:

       if (T-i) >= 0:

           T-=i; kg+=1

       else: t1 = 1

   if t1 == 1: break

print(kg)

Кажись так ~

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота