В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Емсимася
Емсимася
09.09.2020 02:38 •  Информатика

На С++ написать программу Дано натуральное число. Определить, сколько раз в нём встречается первая цифра.

Показать ответ
Ответ:
dhdhdh1
dhdhdh1
11.07.2021 22:41

#include <iostream>

using namespace std;

 

int main()

{

   int N, N1, count=0;

   

   cout << "N="; cin >> N;

   

   N1=N;

   

   while (N>=10)  

   {  

       N/=10;

   }

   

   while (N1)  

   {

       if(N1%10==N) count++;

       N1/=10;

   }

   

   cout << "count=" << count << "\n";

   

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота