В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
KAY111
KAY111
01.09.2022 11:33 •  Информатика

На с++ написать программу вычисляющую значение функции y, которая вычисляется с переменных a, b, x. y=(a^2x^2 -2abx+b^2+1) /(a +b^2)+4, если_x> ab y=(b^2x +4a +x^2)(x +7b^2)+11, если_x=ab y=(x^3 +a^2x +3b) / (2a +b)+9, если_x

Показать ответ
Ответ:
QQQZZZQQQ
QQQZZZQQQ
16.07.2020 15:23
Я так понимаю в третьей строчке должно быть написано x<ab, если да то вот решение:
#include<iostream>
using namespace std;
int main()
{
int y, a, b, x;
cin>>a>>b>>x;
if(x>a*b)
  y=(a*a*x*x-2*a*b*x+b*b+1)/(a+b*b)+4;
if(x=a*b)
  y=(b*b*x+4*a+x*x)*(x+7*b*b)+11;
if(x<a*b)
  y=(x*x*x+a*a*x+3*b)/(2*a+b)+9;
cout<<y;
system("pause");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота