В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
2006464
2006464
25.07.2020 19:15 •  Информатика

На с++ составить программу, которая запрашивает у пользователя два целых числа и выводит сумму квадратов а^2+b^2 этих чисел. пример работы программы a=3 b=2 сумма квадратов равна 13.

Показать ответ
Ответ:
pandaaaaaa1506
pandaaaaaa1506
08.06.2020 19:33

#include <iostream>

#include <cmath>  // подключаем файлы с библиотекой для возведения в степень

using namespace std;

 

int main() {

   long long a, b;  // инициализируем 2 переменных типа long long

   cin >> a >> b;  // вводим числа

   cout << 1LL * (pow(a, 2) + pow(b, 2))  << endl;  // выводим результат

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота