В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
1232959
1232959
25.06.2021 11:54 •  Информатика

На vba: дано число. составить программу, которая определяет. входит ли в него цифра 3.

Показать ответ
Ответ:
madamburkova20
madamburkova20
15.06.2020 21:50

Дам 2 кода на с++ и на паскаль, попробуешь перевести на VBA . не сложно.

с++

int a,b,count(0);;
cin>>a;
while(a>0)
{
b=a%10;
if (b==3) count++;
a/=10;
}
if (count > 0) cout<<"OK";
else cout<<"NO";

 

pascal как то так

uses crt;

var a,b,count:integer;
begin
readln(a);
count:=0;

while a > 0 do
begin
b:=a mod 10;
if b = 3then inc(count);
a:=a div 10;
end;
if count > 0 then writeln('ok')
else
writeln('NO');
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота