В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
maynovetskaya0
maynovetskaya0
11.08.2020 14:34 •  Информатика

На вход программе подаётся n натуральных чисел. найти среднее арифметическое двухзначных чисел кратных трём.
в языке c++ с решением !

Показать ответ
Ответ:
sashaageev04
sashaageev04
10.10.2020 14:31

#include <iostream>

using namespace std;

int main() {

int n, y = 0, x, g = 0;

cin >> n;

for (int i = 0; i < n; i++) {

 cin >> x;

 if (x >= 10 and x <= 99 and x % 3 == 0) {

  g += x;

  y++;

 }

}

cout << g / y;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота