В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
AkLeAfAr
AkLeAfAr
23.03.2023 11:14 •  Информатика

На вход программе подается натуральное число n, затем n строк, затем еще одна строка — поисковый за Напишите программу, которая выводит все введенные строки, в которых встречается поисковый за Формат входных данных
На вход программе подаются натуральное число nn — количество строк, затем сами строки в указанном
количестве, затем один поисковый за Формат выходных данных
Программа должна вывести все введенные строки, в которых встречается поисковый за Примечание. Поиск не должен быть чувствителен к регистру символов.
Пример входных данных:
5
Я вас любил: любовь еще, быть может,
В душе моей угасла не совсем;
Но пусть она вас больше не тревожит;
Я не хочу печалить вас ничем.
Я вас любил безмолвно, безнадежно,
Любил
Вывод программы:
Я вас любил: любовь еще, быть может,
Я вас любил безмолвно, безнадежно,

Показать ответ
Ответ:
Love1011
Love1011
16.10.2020 19:14
//Pascal
//1)
var x, y: integer;
begin
write('Введите x y: ');
read(x, y);
if x > y then
writeln(x - y)
else
 writeln(y - x);
end.

//2)
var a, b, c: integer;
begin
write('Введите a b c: ');
read(a, b, c);
if (a > (b + c)) then
writeln(a)
else
writeln(b + c);
end.

//3)
var x, k: integer;
begin
write('Введите x k: ');
read(x, k);
if k = 1 then
writeln(sin(x))
else
if k = 2 then
writeln(cos(x))
else
writeln('k должен быть равен 1 или 2.');
end.

//4)
var p, m: integer;
begin
  write('Введите p, m: ');
  read(p, m);
  if p > m * 2 then
    writeln(p)
  else
    writeln(m * 2);
end.
0,0(0 оценок)
Ответ:
Dosina
Dosina
16.10.2020 19:14

1)

pass1 = input('Введите пароль: ')

pass2 = input('Введите пароль ещё раз: ')

if str(pass1) == str(pass2):

print('Доступ разрешён')

else:

print('Доступ запрещён')

2)

summ = int(input('Сумма покупки: '))

if summ < 800:

print('Скидка не предоставляется.\n' + 'Сумма покупки: ' + str(summ))

elif 1500 >= summ <= 800:

summ = summ - summ * 0.05

print('Скидка предоставляется в 5%\n' + 'Сумма покупки: ' + str(summ))

elif summ >= 1500:

summ = summ - summ*0.1

print('Скидка предоставляется в 10%\n' + 'Сумма покупки: ' + str(summ))

3)

a = int(input('Введите число: '))

if a > 0:

print('1')

elif a < 0:

print('-1')

elif a == 0:

print('0')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота