В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
рогозина
рогозина
02.02.2022 18:47 •  Информатика

На вход программе подаётся непустая последовательность целых чисел оканчивающаяся отрицательным числом. Написать программу, которая подсчитает среднее арифметическое этих чисел. Последнее введённое число участвует в получении среднего арифметического. Точность выводимого числа не задаётся.
Входные данные
1 3 4 -1
Выходные данные

Показать ответ
Ответ:
nadezdamanuh
nadezdamanuh
14.10.2020 13:00

sr = 0

a = 0

k = 0

while a >= 0:

 a = int(input())

 k += 1

 sr += a

print(sr/k)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота