На вход программе подается последовательность целых чисел от 1 до 5, характеризующее оценку ученика, каждое число на отдельной строке. Концом последовательности является любое отрицательное число, либо число большее 5. Напишите программу, которая выводит количество пятерок.
program z1;
var a,k: integer;
begin
k:=0;
repeat
write ('a = ');
readln (a);
if a = 5 then k:=k+1;
until (a<0) or (a>5);
write ('Количество пятерок равно ',k)
end.