В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
555Sofiya5555
555Sofiya5555
08.07.2021 09:35 •  Информатика

На вход программе подаётся последовательность символов, заканчивающаяся точкой. требуется написать программу, которая определяет, есть ли в этой последовательности цифры, и выводит наибольшее число, которое можно составить из этих цифр. ведущих нулей быть не должно, за исключением одного нуля. если числа нет, выводится сообщение 'no', если число есть - 'да' и в следующей строке искомое число. например, если исходная последовательность была такая: day 10, mice 8: "year" 7 is a mistake 91. то результат должен быть следующий: да 987110

Показать ответ
Ответ:
Файлетмер
Файлетмер
06.10.2020 02:32
Begin
  var s := readstring();
   if(s.Any(x -> x.isDigit)) then
   begin
  if(s.Any(x->x in['1'..'9'])) then
  s.Where(x -> x.IsDigit).OrderByDescending(x -> x).Println
  else
  write(0);
  end
  else
writeln('No');
 end.
0,0(0 оценок)
Ответ:
anisimanis
anisimanis
06.10.2020 02:32
Var
   A:array['0'..'9'] of longint;
   C:char;
   i:integer;
Begin
For C:= '0' to '9' do A[C]:=0;
Repeat
Read(C);
if C in['0'..'9'] then A[C]:=A[C]+1;
Until C = '.';
if (A['1']=0)and(A['2']=0)and(A['3']=0)and(A['4']=0)and(A['5']=0)and(A['6']=0)and(A['7']=0)and(A['8']=0)and(A['9']=0) then
   if A['0']=0 then Write('no')
   else
      Begin
      WriteLn('Да');
      WriteLn(0);
      End
else
   Begin
   WriteLn('Да');
   For C:='9' downto '0' do
       For i:= 1 to A[C] do
           Write(C)
   End
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота