В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kobyarova2001
kobyarova2001
23.09.2022 05:38 •  Информатика

На вход программе подаются два целых числа n и m, каждое в отдельной строке 0

Показать ответ
Ответ:
иван1141
иван1141
07.08.2022 02:07
Самый простой это с операций целочисленного деления разбить общее число секунд на часы, минуты, секунды. Далее собрать нужную строку из получившихся значений, преобразовывая в строки. Учитывая длины получившихся подстрок где надо добавляем 0 слева от начала подстроки.

n = int(input('Число секунд с начала суток: '))
h = n // 3600
n = n % 3600
m = n // 60
s = n % 60
sh = str(h)
sm = str(m)
if len(sm)<2:
    sm = "0"+sm
ss = str(s)
if len(ss)<2:
    ss = "0"+ss
print(sh,':',sm,':',ss)

Тест №1
Число секунд с начала суток: 7200
2 : 00 : 00

Тест №2
Число секунд с начала суток: 75201
20 : 53 : 21
0,0(0 оценок)
Ответ:
D2a0h0a9
D2a0h0a9
05.11.2022 13:39

#include <iostream>

using namespace std;

int main()

{

   int number, max_1, max_2;

   cin >> number;

   max_1 = number;

   while (number != 0)

   {

       cin >> number;

       if (number > max_1)

       {

           max_2 = max_1;

           max_1 = number;

       }

   }

   cout << max_1 << " " << max_2;

}

Объяснение:

Последовательность заканчивается нулём

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()

{

   int number, max_1, max_2; // Создание целочисленных переменных:

number - вводимые числа;max_1 - первый максимум;max_2 - второй максимум.

   cin >> number; // Ввод числа с клавиатуры

   max_1 = number; // Возьмём, что первый максимум = первому числу

   while (number != 0) // Пока значение переменной number ≠ 0

   {

       cin >> number; // Ввод числа с клавиатуры

       if (number > max_1) // Если значение переменной number > значения переменной max_1

       {

           max_2 = max_1; // Второй максимум = первый максимум

           max_1 = number; // Первый максимум = переменной number

       }

   }

   cout << max_1 << " " << max_2; // Вывод ответа через пробел

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота