На вход программы подается n чисел, при том известно, что хотя бы одно из них окажется чётным. определите наибольшее четное число. -в первой строке вводится натуральное число n, (1≤n≤1000) — количество элементов последовательности. в следующей строке через пробел вводятся n целых чисел, каждое из которых по модулю не превосходит 1000. -требуется вывести единстенное число — искомый четный максимум. например 3 2 8 4 8
Привет всему 12 "А" классу(Реальному).Я знаю, зачем вы тут, и я вам Вы знаете меня, как Anxel09.
var a,b,sum,i : integer;
begin
readln(a,b);
if (a < 0) or (a > 10) then
while (a < 0) or (a > 10) do begin
writeln('Число ''a'' не подходит: ');
readln(a);
end;
if (b < 0) or ( b > 10) then
while (a < 0) or (a > 10) do begin
writeln('Число ''b'' не подходит: ');
readln(b);
end;
sum := 1;
for i:= 1 to b do
sum:= sum * a;
writeln('Число ''а'' в степени ''b''',' = ', sum );
end.
Вот и все!
Объяснение:
ответ:1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
var
Chislo, Count, Summa, n: integer;
begin
Summa := 0;
Count := 0;
readln(Chislo);
while Chislo > 0 do
begin
n := Chislo mod 10;
if odd(n) then
begin
Summa := Summa + n;
inc(Count);
end;
Chislo := Chislo div 10;
end;
writeln('Сумма нечетных цифр числа: ', Summa);
writeln('Кол-во нечетных цифр числа: ', Count);
writeln('Среднее арифметическое нечетных цифр: ', Summa / Count);
end.
Объяснение: