В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Пофиг11
Пофиг11
30.10.2021 02:02 •  Информатика

На вход программы подается текст на английском языке, заканчивающийся точкой (другие символы точка в тексте отсутствуют). Требуется написать программу, которая будет определять и выводить на экран английскую букву(в верхнем регистре), встречающуюся в этом тексте чаще всего, и количество там таких букв. Строчные и прописные буквы при этом считаются не различимыми. Если искомых букв несколько, то программа должна выводить на экран первую из них по алфавиту. Входные данные
На вход программы подается непустой текст на английском языке, заканчивающийся точкой (другие символы точка в тексте отсутствуют).

Выходные данные
Один символ - заглавная английская буква и через пробел число - количество таких букв в строке.
Пример:

Ввод
It is not a simple task. Yes!
Вывод
I 3
Ввод
A.
Вывод
B 4
Ввод
Bb Aa Cc A.
Вывод
A 3
Желательно на Питоне или Паскале!

Показать ответ
Ответ:
Intagul
Intagul
09.12.2020 17:37

def letter(text):

   text=text.split('.')

   text=text[0]

   text=text.split()

   text=''.join(text)

   text=text.upper()

   d={}

   for i in set(text):

       d[i]=text.count(i)

   maxim=max(d.values())

   s=0

   for k in d.values():

       if k==maxim:

           s+=1

   

   if s==1:

       for j in d:

           if d[j]==max(d.values()):

               return(f'{j} {d[j]}')

   else:

       qq={}

       for z in d:

           if d[z]==max(d.values()):

               qq[z]=max(d.values())

               

       for l in qq:        

           if l==min(qq.keys()):

               return(f'{l} {qq[l]}')

           

def runner():

   print(letter('It is not a simple task. Yes!'))

   print(letter('A'))

   print(letter('Bb Aa Cc A'))

runner()    

   

Объяснение:

Объяснение писать долго и неудобно) но если кому интересно, могу рассказать, например, через вк или дискорд. Напишите мне в личку

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота