В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Mаjоr
Mаjоr
19.03.2021 00:56 •  Информатика

на языке PASCAL

Напишите программу, которая выводит оси координат и график функции, один на выбор:

1) y=sin(x);

2) y=cos(x);

3) y=x2;

4) y=x3.

Графики строятся в виде точек (если точек много и они очень близки друг другу, то они образуют линию), через цикл FOR – это подсказка для решения.

Показать ответ
Ответ:
артбар
артбар
26.06.2022 07:17
Const
  n=20;
var
  p:array[1..n] of integer;
  i,k,s:integer;
begin
  Randomize;
  Writeln('Последовательность чисел');
  for i:=1 to n do
  begin
    p[i]:=Random(51)-25;
    Write(p[i],' ')
  end;
  Writeln;
  k:=0; s:=0; i:=1;
  repeat
    if p[i]>0 then begin s:=s+p[i]; Inc(k) end;
    Inc(i);
  until (k=4) or (i>n);
  Writeln('Сумма первых четырех положительных чисел равна ',s)
end.
   
Тестовое решение:
Последовательность чисел
-12 6 -21 5 -10 11 19 19 19 17 21 -4 -14 12 2 0 -20 10 17 -14
Сумма первых четырех положительных чисел равна 41
0,0(0 оценок)
Ответ:
софи253
софи253
14.11.2022 21:54

Приведу в пример A и B, они могут принимать два значения истинна и не истинна, тоесть + или -

И

Если A истинно и B истинно, то выражение истинно

если A или B не истинно, то выражение не истинно

ИЛИ

Если или A или B истинно, то выражение истинно

Может быть такое что и A и B истинны, в этом случае выражение тоже истинно

>, <, >=, <=, =

> - больше

< - меньше

>= - больше либо равно

< - меньше либо равно

= - равно

если к примеру A = 10, а B = 20.

A > B? Нет. Выражение не истинно.

A < B? Да. Выражение истинно.

A >= B? Нет. Выражение не истинно.

A <= B? Да. Выражение истинно.

A = B? Нет. Выражение не истинно.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота