На языке паскале сделайте 4 программы
а) Напишите программу, которая получает слово до точки и заменяет все маленькие латинские буквы a в ней на заглавные. Остальные не изменяет.
В этой программе массивы использовать нельзя.
Sample Input:
Sator Arepo tenet opera rotas.
Sample Output:
SAtor Arepo tenet operA rotAs.
б) Напишите функцию, которая получает длину массива чисел и сам массив, а возвращает максимальное нечетное число этого массива.
Sample Input:
5
1 21 30 4 15
Sample Output:
21
в)Напишите программу, которая получает слово до точки и заменяет все маленькие латинские буквы в ней на заглавные и наоборот. Остальные не изменяет.
В этой программе массивы использовать нельзя.
Sample Input:
To be or not To be.
Sample Output:
tO BE OR NOT tO BE.
г) Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму чётных чисел.
В этой программе массивы использовать нельзя.
Sample Input:
4
60
15
0
Sample Output:
3
64
N = 3;
M = 4;
Var
A:array[1..N,1..M] of integer;
i,j,iMin,jMin:integer;
Begin
Randomize;
iMin:=1;
jMin:=1;
WriteLn('Исходный массив:');
For i:= 1 to N do
Begin
For j:= 1 to M do
Begin
A[i,j]:=random(76)-30;
if A[i,j] < A[iMin,jMin] then
Begin
iMin:=i;
jMin:=j
End;
Write(A[i,j]:3,' ')
End;
WriteLn;
End;
WriteLn('Min = A[',iMin,',',jMin,'] = ',A[iMin,jMin]);
End.
Исходный массив:
-11 -3 -16 44
-1 -10 38 -20
33 -22 17 10
Min = A[3,2] = -22
program p1;var i: integer;beginfor i:=1 to 10 dowriteln('5*'+i+'='+5*i);end.
____________________
program p1;var a, b, c, d, e, sum: integer;beginwrite('Введите первое число >> ');read(a);write('Введите втроое число >> ');read(b);write('Введите третье число >> ');read(c);write('Введите четвертое число >> ');read(d);write('Введите пятое число >> ');read(e);sum:=a+b+c+d+e;writeln('Сумма введенных чисел: '+sum);end.