В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

НА ЯЗЫКЕ ПРГОРАМИРОВАИЯ Напишите программу по следующему описанию:
a. двум переменным присваиваются числовые значения;
b. если значение первой переменной больше второй, то найти разницу значений переменных (вычесть из первой вторую), результат поместить в третью переменную;
c. если первая переменная имеет меньшее значение, чем вторая, то в третью переменную поместить результат суммы значений двух первых переменных;
d. Если переменные равны, присвоить третьей переменной значение первой переменной;
e. вывести значение третьей переменной на экран.

Показать ответ
Ответ:
Obmorok33
Obmorok33
24.03.2020 09:28
     «Плоский мир» (англ. Discworld — буквально «Мир-диск») — серия книг Терри Пратчетта, написанных в жанре юмористического фэнтези.
     Действие книг происходит на фантастической планете. Планета эта, как понятно из названия, плоская и имеет форму диска. В этом мире свои законы физики: свет здесь движется медленно, магия материальна, а в радуге восемь цветов. В этом мире возможно всё; то, что мы считаем мифами, там — правда. Плоский мир покоится на спинах четырёх слонов, которых держит гигантская черепаха Великий А’Туин, плывущая сквозь космическое пространство.
     Плоский мир населен различными расами: тролли, гномы, эльфы, големы, вампиры, оборотни, зомби — все они не просто сосуществуют в этом мире, но и борются за свои права и равенство при приеме на работу.
     Книги о Плоском мире можно условно разделить на несколько подциклов, каждый из которых имеет своих героев и место действия (при этом они могут пересекаться). Герои основных подциклов:
   I. Ринсвинд — «Волшебник», выпускник Незримого Университета, абсолютно не к магии по мнению преподавателей Незримого Университета и величайший волшебник Плоского мира по факту: он мир. Владелец Сундука.
   II. Ланкрские Ведьмы. Самые известные представительницы — матушка Ветровоск, сильнейшая ведьма Диска, и нянюшка Ягг, автор «Песни про ёжика». Их магия — особая, иная, чем у волшебников: чтобы зажечь огонь, ведьма долго и пристально смотрит на бревно, пока бревно не сгорит со стыда.
   III. Смерть — антро сущность мужского рода (скелет с косой на белом коне)
   IV. Городская стража — охраняет порядок  Анк-Морпорка, самого большого города Плоского Мира.
   V. Тиффани Болит — героиня «детского» подцикла, юная ведьма из Мела.
   VI. Мойст фон Липвиг — герой одного из городских подциклов, авантюрист, принятый на государственную службу Анк-Морпорка.
     Книги серии «Плоский мир» завоевали громадную популярность благодаря тонкому юмору и глубокой, но ненавязчивой философии.
0,0(0 оценок)
Ответ:
Неуч00
Неуч00
22.07.2020 04:37

//Обьявляем дополнительные переменные и главный массив, а также два дополнительных - они будут "половинками".

var

 a, b, c: array [1..100] of longint;

 i, min, n, j, t: longint;

begin

 //Читаем количество элементов в нашем массиве.

 readln(n);

 

 //Читаем массив.

 for i := 1 to n do read(a[i]);

 

 //Заполняем первую "половинку".

 for i := 1 to n div 2 do b[i] := a[i];

 

 //Заполняем вторую "половинку". Но раз это уже вторая "половинка" главного массива, то и

 //цикл теперь должен начинаться со второй части массива, а заканчиваться уже в его конце.

 for i := n div 2 + 1 to n do c[i - n div 2] := a[i];

 

 //Теперь отсортируем первую "половинку" методом выбора. Идея этого метода

 //основывается на том, что мы ищем минимальный среди неотсортированных элемент,

 //а затем аем его с тем, который стоит сразу после отсортированных.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if b[min] > b[j] then

       min := j;

   if min <> i then begin

     t := b[i];

     b[i] := b[min];

     b[min] := t;

   end;

 end;

 

 //Затем вторую точно также, только стоит обратить внимание на сравнения.

 //Так как надо отсортировать по убыванию, то теперь сравнение перед "swap"-ом

 //будет другим.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if c[min] < c[j] then

       min := j;

   if min <> i then begin

     t := c[i];

     c[i] := c[min];

     c[min] := t;

   end;

 end;

 

 //А теперь по очереди выводим готовые "половинки", не забывая ставить

 //пробел после вывода каждого элемента.

 for i := 1 to n div 2 do write(b[i], ' ');

 for i := 1 to n - n div 2 do write(c[i], ' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота