В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
asdfdsf01oziqid
asdfdsf01oziqid
08.04.2020 14:09 •  Информатика

⦁ На языке PYTHON написать программу вычисления мощности с использованием функции

Показать ответ
Ответ:
inara12345
inara12345
25.03.2021 20:59

1. смешанная адресация

2. то же значение, что в В2

3. =B4*($C$2+D3)

4. ошибка, С$5 выйдет за пределы таблицы

5. =$D6+E6

Объяснение:

1. один знак $ - смешанная, нет знаков $ - относительная, два знака $ - абсолютная

2. то же значение, что в B2, т.к. абсолютная адресация

3. у ячеек с относительной адресацией увеличился номер строки на 1

4. ошибка связана с тем, что формула копируется в ячейку, находящуюся на 3 столбца левее, а столбец С в ссылке С$5 может быть изменен максимум до столбца А, то есть на 2 левее

5. столбец D не изменяется т.к. слева $, а остальные значения будут меняться при копировании

0,0(0 оценок)
Ответ:
Polly2011
Polly2011
22.11.2021 17:55
Const n=10; 
type ar=array[1..n+1] of integer;
var 
a:ar; i,p:integer; 
procedure pr(var a:ar; p:integer; var k:integer);
begin
k:=1;
while a[k]<>p do k:=k+1;
end;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(31);
 write(a[i]:4);
 end;
writeln;
p:=17;
a[n+1]:=p;
pr(a,p,i);
if i<n 
 then writeln('Значение 17 найдено, номер элемента = ',i)
 else writeln('Значения 17 в массиве нет');
end.

Пример:
Массив A:
  14   5   7  17  25  15  28   0  24   0
Значение 17 найдено, номер элемента = 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота