В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
JHOOOOOOPE
JHOOOOOOPE
12.05.2020 17:20 •  Информатика

На языке Си. 1) Написать программу, реализующие алгоритмы сортировки массивов чисел по возрастанию и по убыванию. Входными параметрами для функций должно быть число элементов в массиве и указатель на сам массив.

2) Разработать программу, содержащую функцию для решения суммы членов математического ряда( на скриншоте)


На языке Си. 1) Написать программу, реализующие алгоритмы сортировки массивов чисел по возрастанию и

Показать ответ
Ответ:
крыска235
крыска235
17.02.2022 06:00

Відповідь:

#include <stdio.h>

#include <iostream>

#include <cstdlib>

#include <time.h>

using namespace std;

void randarr(int *arr,int size){

for(int i = 0; i < size; i++){

 arr[i] = rand() % 40 + 0;

}

}

void printarr(int *arr,int size){

for(int i = 0; i < size; i++){

 printf("%d\t", arr[i]);

}

}

void sortminmax(int *arr,int size){

for(int i = 0; i < size - 1; ++i){

 int small = i;

 for (int j = i + 1; j < size; ++j){

  if (arr[j] < arr[small]){

   small = j;

  }

 }

 swap(arr[i], arr[small]);

}

}

void sortmaxmin(int *arr,int size){

for(int i = 0; i < size - 1; ++i){

 int big = i;

 for (int j = i + 1; j < size; ++j){

  if (arr[j] > arr[big]){

   big = j;

  }

 }

 swap(arr[i], arr[big]);

}

}

int main(){

srand(time(NULL));

setlocale(LC_ALL, "Rus");

int size;

printf("Введите размер массива: ");

scanf("%d" , &size);

int *arr = new int[size];

printf("Массив: ");

randarr(arr,size);

printarr(arr,size);

printf("\nСортируем массив по возрастанию от наименьшего до наибольшего...");

printf("\nРезультат: ");

sortminmax(arr,size);

printarr(arr,size);

printf("\nСортируем массив по убыванию от наибольшего до наименьшего...");

printf("\nРезультат: ");

sortmaxmin(arr,size);

printarr(arr,size);

delete[] arr;    

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота