В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
chuksin2008
chuksin2008
12.05.2022 17:17 •  Информатика

На языке СИ написать программу В функцию передаются 4 числа. Определить наименьшее и наибольшее из этих чисел. Результат поместить в 2 глобальные переменные.

Показать ответ
Ответ:
алисатян2
алисатян2
07.03.2021 19:40

#include <stdio.h>

float gmax, gmin;

void privet(float a, float b, float c, float d) {

   float x[4], max, min;

   x[0] = a;

   x[1] = b;

   x[2] = c;

   x[3] = d;

   max = a;

   min = a;

   for (int i = 0; i < 4; i++) {

       if (max <= x[i])

           max = x[i];

       else if (min >= x[i])

           min = x[i];

   }

   gmax = max;

   gmin = min;

}

int main()

{

   float c1, c2, c3, c4;

   scanf("%f%f%f%f", &c1, &c2, &c3, &c4);

   privet(c1, c2, c3, c4);

   printf("Max:%f\nMin:%f", gmax, gmin);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота