В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Arinkaah
Arinkaah
14.11.2022 15:49 •  Информатика

На языке си. напишите программу, которая получает два целых числа a и b (0 < a < b) и выводит квадраты всех натуральных чисел в интервале от a до b. пример: введите два целых числа: 10 12 10*10=100 11*11=121 12*12=144

Показать ответ
Ответ:
ermekbaevadinara
ermekbaevadinara
31.08.2020 06:57
#include <iostream>
#include <conio.h>
using namespace std;

int main()
{
    setlocale(LC_ALL,"Russian");
    unsigned long long A,B;
    cout << "Введите A(Начало) и B(Конец):\t";
    cin >> A >> B;
    if (A>0)
        for (unsigned long long i=A; i<=B; i++)
            cout << i << "\t - \t" << i*i << endl;
    else
    {
        cout << "Ошибка!";
        _getch();
        return -1;
    }
    _getch();
    return 0;
}

P.S. Это моя старая программа на C++, ПИСАЛ ЕЁ ДАВНО, использовал Microsoft Visual C++ 2010.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота