В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kkhristinka1
kkhristinka1
08.11.2021 19:57 •  Информатика

На завтра ! напишите программу, которая определяет полиндром четырехзначное число или нет. можно в паскале !

Показать ответ
Ответ:
vanessashevchuk
vanessashevchuk
10.06.2020 19:21

var n:integer;

BEGIN

  read(n);

  if (n > 9999 or n<1000) then

    writeln('Вы дурак')

  else  begin

     if (n mod 10 = n div 1000 and n mod 100 div 10 = n div 100 mod 10) then

        writeln('Полиндром')

     else writeln('Нет');

  end;

END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота