В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Tania22012003
Tania22012003
12.01.2021 08:50 •  Информатика

Набор текста PYTHON 3 Алишер и Сержан соревнуются в быстром наборе текста. Им дается текст с S набором символов, скорость набора текста Алишера V1 символов в миллисекунду, а Сержан набирает V2 символов в миллисекунду. Также перед и после набора текста у них происходит ping(задержка обработки за на сервере), то есть, перед тем как получить текст и отправить его обратно на онлайн платформу . У Алишер T1 миллисекунд, а у Сержана T2 миллисекунд.
Последовательность выполнения действий является следующее:
Алишеру и Сержану в течении T1 и T2 времени приходит текст.
Затем как только текст пришел каждый начинает набор текста.
Затем как только они закончили набор текста они отправляют текст обратно за T1 и T2 времени.
Победителем является тот чей текст система обработала быстрее. Напишите программу, которая вычислит, кто является победителем.
Вводные данные:
На первой строке число S, количество символов в тексте.
На второй строке число V1 скорость набора текста Алишера.
На третьей строке число V2, скорость набора текста у Сержана.
На четвертой строке T1 ping в миллисекундах у Алишера.
На пятой строке T2, ping в миллисекундах у Сержана.
Выходные данные:
На одной строке если выиграл Алишер, имя "Alisher". Если выиграл Сержан, имя "Serzhan", а если текст обоих обработал в одно время слово "Friendship".
Пример 1
Ввод:
5
1
2
1
2
Вывод:
Alisher

Показать ответ
Ответ:
Adilkin
Adilkin
31.01.2021 19:10
uses crt; var s:string;     c:char;     m:set of char;     n,i,k,p:byte; begin writeln('Введите текст из строчных латинских букв, окончаание ввода Enter'); s:=''; repeat c:=readkey; if c in ['a'..'z'] then  begin   write(c);   s:=s+c;  end; if c=#13 then writeln until c=#13; n:=length(s); m:=[]; for c:='a' to 'z' do  begin   k:=0;   for i:=1 to n do   if s[i]=c then k:=k+1;   if k>1 then m:=m+[c];  end; if m=[] then write('Нет букв, встречающихся более 1 раза') else  for c:='a' to 'z' do  if c in m then write(c) end.
0,0(0 оценок)
Ответ:
nicsiberia
nicsiberia
19.05.2020 06:15
Var   a: array[1..20,1..20] of integer;   n,m,i,j,min,jm,x: integer; begin   randomize;   write('Введите размеры массива: ');   readln(n,m);   writeln('Исходный массив:');   for i:=1 to n do   begin     for j:=1 to m do     begin       a[i,j]:=random(19)-9;       write(a[i,j]:4);     end;     writeln;   end;   min:=0;   for i:=1 to n do min:=min+a[i,1];   writeln('Сумма элементов 1-го столбца = ',min);   jm:=1;   for j:=2 to m do   begin     x:=0;     for i:=1 to n do       x:=x+a[i,j];     writeln('Сумма элементов ',j,'-го столбца = ',x);     if x<min then     begin       min:=x;       jm:=j;     end;   end;   writeln('Минимальная сумма в ',jm,'-м столбце');   writeln('Полученный массив:');   for i:=1 to n do   begin     for j:=1 to m do     begin       if j<>jm then a[i,j]:=a[i,jm];     write(a[i,j]:4);     end;     writeln;   end;   readln; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота