Начертить блок схемы к задачам из питона «Минимум из двух чисел» Даны два целых числа. Выведите значение наименьшего из них; «Шахматная доска» Заданы две клетки шахматной доски. Если они покрашены в один цвет, то выведите слово YES, а если в разные цвета — то NO. Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки; «Високосный год Дано натуральное число. Требуется определить, является ли год с данным номером високосным. Если год является високосным, то выведите YES, иначе выведите NO. Напомним, что в соответствии с григорианским календарем, год является високосным, если его номер кратен 4, но не кратен 100, а также если он кратен 400. Шоколадка Шоколадка имеет вид прямоугольника, разделенного на n×m долек. Шоколадку можно один раз разломить по прямой на две части. Определите, можно ли таким образом отломить от шоколадки часть, состоящую ровно из k долек. Программа получает на вход три числа: n, m, k и должна вывести YES или NO.» Сколько совпадает чисел Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из чисел: 3 (если все совпадают), 2 (если два совпадает) или 0 (если все числа различны).
2. Мощность алфавита - это кол-во символов в нём
3. Ic=i*k , Ic – количество информации в сообщении, i – количество информации которое несет один знак, k – количество знаков в сообщении
4. Т.к. каждый символ может иметь 64 значения, то есть 2^{6} , то на каждый символ выделяется 6 бит(от 0 до 63, всего 64 варианта).Всего символов - 100. Значит всего нужно 6*100=600бит=75байт.
5. Это единицы размера полученной и переданной информации и размера файла.
Килобайт = 1024 байт
Мегабайт = 1024 килобайт
Гигабайт = 1024 мегабайт
6. Дано: текст 3.5 килобайта
Найти: количество символов в тексте
Решение: Итак, текста у нас 3.5 килобайта
Переведём в байты:
3.5 кбайта * 1024 байт\килобайте = 3584 байт.
Так как кодировка не указана выбираем саму распространенную при обучении однобайтовую, тогда символ занимает ровно один байт и значит у нас
3584 символа. Если же используется двухбайтная кодировка, то 3584/2 = 1792 символа
ответ: 3584 для одного байта на символ или 1792 сиволов для двух байтной кодировки.
7. В первом тексте информационный объем одного символа составляет
N=2^i
32=2^5
i=5 бит
Во втором текте
64=2^6
i=6
Значит, в 1,2 раза (6:5=1,2)
// Внимание! Если программа не работает, обновите версию!
type
tL=List<integer>;
function Avg(L:tL):=L.Average;
function Cont(L:tL; e:integer):=L.Contains(e);
function Occurs(L:tL; e:integer):=L.Where(t->t=e).Count;
begin
var MyList:=Lst(3,8,12,5,16,9,5,-2,7,0,5,-1);
MyList.Println;
Writeln('Среднее равно ',Avg(MyList):0:3);
var k:=ReadInteger('Введите элемент для поиска:');
Writeln('Есть ли такой элемент в списке? ',Cont(MyList,k));
Writeln('Количество таких элементов равно ',Occurs(MyList,k))
end.
Пример
3 8 12 5 16 9 5 -2 7 0 5 -1
Среднее равно 5.583
Введите элемент для поиска: 5
Есть ли такой элемент в списке? True
Количество таких элементов равно 3