Надо к завтрашнему : составьте программу в паскале вычислите площадь треугольника , две стороны которого равны а и b , а угол между ними равен d (в градусах)
Program zd; const t=0,5; var a,b,c:byte; r,s:real; begin writeln('Введите сторону А'); readln(a); writeln('Введите сторону В'); readln(b); writeln('Введите угол С (в градусах)'); readln(c); r:=c*pi/180; {Перевод из градусов в радианы} s:=t*a*b*sin(r); {Формула для вычисления} writeln('Результат = ',s); readln; {Сразу выводит результат на монитор без нажатия Ctrl+F9 (вроде бы)} end. Вроде бы так, попробуй запустить проверить
const
t=0,5;
var
a,b,c:byte;
r,s:real;
begin
writeln('Введите сторону А');
readln(a);
writeln('Введите сторону В');
readln(b);
writeln('Введите угол С (в градусах)');
readln(c);
r:=c*pi/180; {Перевод из градусов в радианы}
s:=t*a*b*sin(r); {Формула для вычисления}
writeln('Результат = ',s);
readln; {Сразу выводит результат на монитор без нажатия Ctrl+F9 (вроде бы)}
end.
Вроде бы так, попробуй запустить проверить