В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
FreonTime
FreonTime
16.06.2020 15:22 •  Информатика

Надо написать на паскале в заданном массиве определите количество элементов,которые меньше заданного с клавиатуры числа

Показать ответ
Ответ:
Maria150305
Maria150305
14.08.2020 09:26
Const
  n=10;
var
  i,m,k:integer;
  a:array[1..n] of integer;
begin
  Randomize;
  Write('Исходный массив: ');
  for i:=1 to n do begin a[i]:=Random(90)+10; Write(a[i],' ') end;
  Writeln;
  Writeln('Введите целое число: '); Read(m);
  k:=0;
  for i:=1 to n do
    if a[i]<m then Inc(k);
  Writeln('Количество чисел, меньших ',m,' равно ',k)
end.

Тестовое решение:
Исходный массив: 42 89 49 25 96 87 94 93 41 28
Введите целое число:
50
Количество чисел, меньших 50 равно 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота