В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
AcidSmile
AcidSmile
06.06.2022 12:44 •  Информатика

Надо написать программу определяющую характеристику произвольного числа введённого через клавиатуру.

Показать ответ
Ответ:
iIИльяIi
iIИльяIi
25.05.2020 22:53

var a:integer;

begin

write('Введите произвольное число'); readln(а);

if a = 0 then begin

writeln ('Введен нуль');

exit;

end;

if а > 0 then writeln ('Число положительное');

else writeln ('Число отрицательное');

if a mod 2 = 0 then writeln('Число четное');

if a mod 3 = 0 then writeln('Число кратно 3');

if a mod 5 = 0 then writeln('Число кратно 5');

if a mod 7 = 0 then writeln('Число кратно 7');

if a mod 9 = 0 then writeln('Число кратно 9');

if a mod 10 = 0 then writeln('Число кратно 10');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота