В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Надо написать программу, определяющую сколько слов в тексте начинается на букву "а". (паскаль)

Показать ответ
Ответ:
maks2614
maks2614
10.10.2020 19:12

uses crt;

var  st,buf:string;

k:integer;

begin

k:=0;

clrscr;

write('-> ');

readln(st);

repeat

 if (st[1]=' ') or (length(st)=0) then while st[1]=' ' do delete(st,1,1)

 else

 begin

  while (st[1]<>' ') and (length(st)>0) do

  begin

   buf:=buf+st[1];

   delete(st,1,1);

  end;

 if upcase(buf[1])='A' then inc(k);

 buf:='';

 end;

until (length(st)=0) and (length(buf)=0);

writeln(k);

readln;

end.

Объяснение:

0,0(0 оценок)
Ответ:
valyakravets
valyakravets
10.10.2020 19:12

Program bykvaa;

Uses crt;

Var  

a:string;

b,i:integer;

begin

writeln('Введите текст:');

readln(a);

if a[1]='а' then b:=b+1;

for i:=2 to length(a) do

begin

 if a[i]='а' then if a[i-1]=' ' then b:=b+1;

end;

writeln('Количество слов в тексте, начинающихся на букву "а": ',b);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота