В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ilin265ilinMiha
ilin265ilinMiha
17.09.2022 12:03 •  Информатика

Надо написать программу паскаль,которая
а)Просит ввести количество людей,затем просит ввести их массу и выводит на экран их общюю массу
б)В этой же программе надо добавить их среднюю массу.
в) В этой же программе надо чтоб программа выводила на экран информацию,могут ли люди ехать в лифте чья грузоподъёмность 300 кг
даю.

Показать ответ
Ответ:
Sasha11111222
Sasha11111222
04.03.2021 22:55

var n, k, i:integer;

m:real;

begin

   readln(n);

   

   for i:=1 to n do

       begin

           readln(k);

           m := m + k;

       end;

   

   writeln('Общая масса: ', m);

   writeln('Средняя масса: ', m/n);

   

   if (m < 300) then

       begin

           writeln('Люди могут ехать!');

       end

   else

       writeln('Ехать нельзя!');

end.

Объяснение:

б)В этой же программе надо добавить их среднюю массу.

Не совсем понял куда добавить, поэтому вывел.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота