В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Janiya1404
Janiya1404
15.02.2023 04:32 •  Информатика

Надо написать программу в которую водишь 2 значения: 1) собственный год рождения (2005)
2) год который сейчас
Программа обрабатывает и выдаёт сколько тебе будет лет в ближайшем високосном году

Показать ответ
Ответ:
qwaszxpolkmn129
qwaszxpolkmn129
22.01.2021 22:03

#include <iostream>

using namespace std;

int main() {

   int br_year, th_year;

   cin >> br_year >> th_year;

   

   for(;;th_year++) {

       if(th_year % 4 == 0 || th_year % 100 != 0 && th_year % 400 == 0) {

           break;

       }

   }

   

   cout << "Ближайший високосный год будет в " << th_year << " году, на этот момент Вам будет " << th_year - br_year << " лет.";

   

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота