В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
guast1
guast1
04.05.2022 08:23 •  Информатика

Надо написать программу в паскале. : введите три трёхзначных числа. найти разность между наибольшим м наименьшим. заранее !

Показать ответ
Ответ:
hola174
hola174
07.07.2020 14:37
Begin
  var a, b, c: single;
  readln(a, b, c);
  writeln(max(a, max(b, c)) - min(a, min(b, c)));
end.

Позязя, расширеннее...
begin
  var a, b, c, d, e: single;
  readln(a, b, c);
  if (a < b) then
    d := a
  else
    d := b;
  if (c < d) then
    d := c;
  if (a > b) then
    e := a
  else
    e := b;
  if (c > e) then
    e := c;
    writeln(e - d);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота