В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Nikto58
Nikto58
15.02.2021 06:11 •  Информатика

надо очень Напишите программу, которая вычисляет значение функции у и выводит его на экран. Значение переменной x вводится с клавиатуры. =24 − 5+,если х<10 = 52−,если 10 <=<13 =73−5,если >=13

Показать ответ
Ответ:
6классКZ
6классКZ
18.07.2022 19:49
Const
  n = 5;{ это позволяет в одном месте изменить количество чисел }

type
  numeric = real;{ это позволяет в одном месте изменить тип чисел }

var
  max, min: numeric;
  i: integer;
  a: array[1..n] of numeric;

begin
  Writeln('Введите ', n, ' произвольных чисел через пробел');
  Read(a[1]);
  min := a[1]; max := min;
  for i := 2 to n do
  begin
    Read(a[i]);
    if max < a[i] then max := a[i]
    else
    if min > a[i] then min := a[i]
  end;
  Writeln('Минимальное введенное: ', min, ', максимальное: ', max)
end.

Тестовое решение:
Введите 5 произвольных чисел через пробел
34 157 -84.54 14.843 -13.64
Минимальное введенное: -84.54, максимальное: 157
0,0(0 оценок)
Ответ:
lol1025
lol1025
29.05.2022 23:15
Var n,a,b,i,min:integer;
mass:array[1..100000] of integer;
begin
writeln('Введите кол-во элементов массива');
read(n);
writeln('Введите числа');
for i:=1 to n do// задаем массив пока i не станет равно n (i:=i+1 )
read(mass[i]);//считываем массив с индексом i
min:=mass[1];// обозначаем первый элемент массива за первый
b:=1;// индекс от первого элемента массива
for i:=1 to n do//цикл задаем массив пока i не станет равно n (i:=i+1 )
if mass[i]<min then begin//при условии что массив будет меньше первого числа то
b:=i;// обозначаем индекс
min:=mass[i];// обозначаем новый минимальный массив
end;
for i:=1 to b-1 do// задаем массив пока i не станет равно b-1 (i:=i+1 ); и еще b-1 значит чтобы само число b не входило в цикл
mass[i]:=mass[i]*mass[b];// домножаем на меньший массив
writeln('Полученный массив');// вывод массива
for i:=1 to n do
write(mass[i]:6);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота