В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Маргошка55
Маргошка55
15.06.2020 06:16 •  Информатика

Надо сдать! написать программу на языке с++ дана последовательность n различных целых чисел. найти сумму ее членов,расположенных между максимальным и минимальным значениями(в сумму включить и оба этих числа).

Показать ответ
Ответ:
Pppddddd
Pppddddd
07.10.2020 03:11
#include <iostream>
using namespace std;
int main()
{
 int n,max, min, pos1, pos2, mem, sum;
cin >> n;
pos1 = 0;
pos2 = 0;
int *A = new int[n];
for (int i = 0; i < n; i++)
{
 cin >> A[i];
}
min = A[0];
max = A[0];
for (int i = 0; i < n; i++)
 {
 if (A[i] > max)
 {
  max = A[i];
  pos1 = i;
 }
 if (A[i] < min)
 {
  min = A[i];
  pos2 = i;
 }
}
if (pos2 > pos1)
{
 mem = pos2;
 pos2 = pos1;
 pos1 = mem;
}
sum = 0;
for (pos2; pos2 <= pos1; pos2++)
{
 sum = sum + A[pos2];
}
cout << sum;
system("pause");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота