В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
JAHGH
JAHGH
30.07.2020 04:50 •  Информатика

Надо составить программу.

Показать ответ
Ответ:
Саша77777777
Саша77777777
09.04.2023 00:42
1.
var s:string; m1,m2,m3:integer;
begin
writeln('- Привет! Я компьютер, а как тебя зовут?');
write('- '); readln(s);
writeln('- ',s,', введи свои оценки по 3 предметам');
write('- '); readln(m1,m2,m3);
writeln('- ',s,', твой средний ', (m1+m2+m3)/3);
end.

Пример:
- Привет! Я компьютер, а как тебя зовут?
- Алёна
- Алёна, введи свои оценки по 3 предметам
- 4 4 4
- Алёна, твой средний 4

2.
var a,b:integer;
begin
write('a = '); readln(a);
b:=(a div 100)*100 + (a mod 10)*10 + (a div 10 mod 10);
writeln('b = ',b);
end.

Пример:
a = 123
b = 132
0,0(0 оценок)
Ответ:
ladygum78
ladygum78
01.06.2023 14:21
Внешняя память - это память, предназначенная для длительного хранения программ и данных. Целостность содержимого ВЗУ не зависит от того, включен или выключен компьютер

Дисковод (накопитель) - устройство записи/считывания информации. Накопители имеют собственное имя – буква латинского алфавита, за которой следует двоеточие. Для подключения к компьютеру  одного или несколько дисководов и управления их работой нужен Дисковый контроллер

Носитель информации (носитель записи) – материальный объект хранить информацию. Информация записывается на носитель посредством изменения физических, химических и механических свойств запоминающей среды

По типу доступа к информации внешнюю память делят на два класса:

Устройства прямого (произвольного) доступа –  время обращения к информации не зависит от места её расположения на носителе;

Устройство последовательного доступа – такая зависимость существует

В состав внешней памяти входят:  1) накопители на жестких магнитных дисках (НЖМД);  2) накопители на гибких магнитных дисках (НГМД);  3) накопители на магнитооптических компакт дисках;  4) накопители на оптических дисках (CD-ROM);  5) накопители на магнитной ленте и др.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота