В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
HappyPerson23
HappyPerson23
11.04.2022 11:33 •  Информатика

Надо составить программу для паскаль abc дано вещественное число.если оно отрицательное, вывести на экран его модуль, а если нет, то вычислить из него квадратный корень.

Показать ответ
Ответ:
Molyaneya
Molyaneya
25.05.2020 21:54

var

  a: real; 

 

begin

  writeln('Введите вещественное число');

  readln(a);  //Вводим вещественное число

  if a < 0 then writeln('Модуль числа а: ', abs(a))  {Если введенное число - отрицательное, печатаем его модуль, иначе печатаем квадратный корень из этого числа с округлением до 5 знаков после запятой}

  else writeln('Квадратный корень из числа а: ', sqrt(a) : 0 : 5);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота