В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Viper397
Viper397
27.01.2020 15:41 •  Информатика

Надо составить программу на паскале, которая будет писать все положительные значения f(x) на интервале от a до b с шагом h. Функция F(x) = 2cos(x)-1


Надо составить программу на паскале, которая будет писать все положительные значения f(x) на интерва

Показать ответ
Ответ:
Makcuм
Makcuм
20.06.2021 19:41

Program trig;

var a,b,H:real;

Function F(n:real):real;

begin

F:=2*cos(n)-1;  

end;

begin

write('Введите шаг: ');

readln(H);

write('Введите интервал: ');

readln(a,b);

writeln('x    F(x)');

writeln('');

while a<=b do begin

 if(F(a) > 0) then writeln(a:0:2,'  ',F(a):0:2);

 a:=a+H;

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота