В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nick12321
Nick12321
18.03.2021 06:40 •  Информатика

Надо составить программу в паскале, в которой надо найти процент от заданного числа

Показать ответ
Ответ:
ваня2007123
ваня2007123
27.05.2020 21:28
Var     
q: Single; // Результат. Если число будет больше, то указать Double
i: Single; // Число из которого необходимо получить результат. Если число будет больше, то указать Double
p: Single; // Процент. Если процент будет всегда целым числом, то указать Byte
begin 
writeln('Введите число => '); 
read(i); 
writeln('Введите процент, который хотите расcчитать из введенного числа => ');   
read(p); 
while p < 0 do
begin     
writeln('Процент не может быть меньше нуля, введите новое значение => ');   
read(p);   
end; 
q:=(i / 100) * p; 
writeln('Ваш результат из числа => ', i, ', ', p, '% = ', q);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота