В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
angelina2005hs
angelina2005hs
01.02.2020 16:34 •  Информатика

Надо в pascal составить программу. 1) задает следующие вопросы и позволяет ввести ответы: как тебя зовут? введи номер класса в котором ты учишься. 2) выдает фразу : имя, закончишь школу в году. верно? да/нет. 3) позволяет ввести ответ и анализирует его: если ответ да, то выводит фразу: " ай да я! ай да молодец! " если ответ нет, то выводит фразу: " ой! неужели ошиблась? ! " если ответ ни да, ни нет, то выводит фразу: " хм! вечный школьник? ! "

Показать ответ
Ответ:
masaberegovenko
masaberegovenko
04.10.2020 05:53
Begin 
  var N,X: string;  
  var K,Y: integer;
  var M: longint;
  writeln ('Как тебя зовут? ');
  readln(N);
  writeln ('Введи номер класса в котором ты учишься. ');
  readln(K);  Y:=2016+1+11-K;
  writeln (N,' закончишь школу в ',Y,' году. Верно? да/нет. ');
  read(X);
    if X='да'
      then writeln ('Ай да я! Ай да молодец!')
      else
          if X = 'нет'
          then writeln ('Ой! Неужели ошиблась?!')
          else writeln ('Хм! Вечный школьник?!');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота