Написать и отладить программу на языке с++. для отладки используйте массив из 3-4 структур.
в отчёте хранится информация об изобретательской деятельности кафедр за три года: наименование кафедр, количество заявок, количество положительных решений. написать программу определения кафедры получившей максимальное количество положительных решений
handsfree = true;
type
mas100_100 = array[1..100, 1..100] of integer;
var
a1, a2, a3: mas100_100;
i, j, m, n: integer;
procedure InitializeMatrix(var a: mas100_100; m, n: integer);
var
i, j: integer;
begin
writeln('Данные матрицы');
for i := 1 to m do
begin
for j := 1 to n do
if handsfree then begin
a[i, j] := random(30);
write(a[i, j]:2, ' ')
end
else
read(a[i, j]);
writeln;
end;
end;
begin
writeln('Введите размер матриц');
readln(m, n);
InitializeMatrix(a1, m, n);
InitializeMatrix(a2, m, n);
writeln('Вывод результата');
for i := 1 to m do
begin
for j := 1 to n do
begin
a3[i, j] := a1[i, j] * a2[m + 1 - i, n + 1 - j];
write(a3[i, j], ' ');
end;
writeln;
end;
readln;
end.
handsfree = true;
type
mas100_100 = array[1..100, 1..100] of integer;
var
a1, a2, a3: mas100_100;
i, j, m, n: integer;
procedure InitializeMatrix(var a: mas100_100; m, n: integer);
var
i, j: integer;
begin
writeln('Данные матрицы');
for i := 1 to m do
begin
for j := 1 to n do
if handsfree then begin
a[i, j] := random(30);
write(a[i, j]:2, ' ')
end
else
read(a[i, j]);
writeln;
end;
end;
begin
writeln('Введите размер матриц');
readln(m, n);
InitializeMatrix(a1, m, n);
InitializeMatrix(a2, m, n);
writeln('Вывод результата');
for i := 1 to m do
begin
for j := 1 to n do
begin
a3[i, j] := a1[i, j] * a2[m + 1 - i, n + 1 - j];
write(a3[i, j], ' ');
end;
writeln;
end;
readln;
end.