В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Max2934
Max2934
07.01.2022 07:36 •  Информатика

Написать код на паскаль Чтобы подсчитывал средний по оценкаи
Пример
Водишь оценки 5345 и выдает средний
Без масивов но чтобы был repeat,until

Показать ответ
Ответ:
Penguinunicirn
Penguinunicirn
20.12.2022 17:44

Вводим кол-во элементов

Создаём список

Перебираем i от 0 до n

Вводим элемент массива

Добавляем введённый элемент в список

Выводим сообщение со списком

Вводим кол-во элементов

Вводим позицию старта

Перебираем i от 0 до m

Создаём переменную buffer, которая равна элементу списка k+i-1, то есть позиции старта, плюс i и минус 1

Элементу списка k+i-1 присваиваем элемент списка, который находиться на i-индексе.

Присваиваем элементу списка с индексом i, переменную buffer.  

Объяснение:

Данный код меняет элементы местами в списке, в определённом промежутке.

0,0(0 оценок)
Ответ:
sobkevichbozhep08t40
sobkevichbozhep08t40
22.01.2020 01:31

1.

program z1;

var k: integer;

begin

write ('Введите число: ');

readln(k);

if k > 0 then k:=k*2

else k:=sqr(k);

write('Сейчас число: ',k)

end.

2.

program z2;

uses GraphABC;

var k: integer;

begin

SetFontSize(15);

write ('Введите число: ');

read(k);

write(k);

if k mod 2 = 0 then

begin

SetBrushColor(clred);

FillRectangle(220,140,420,340)

end

else

begin

SetBrushColor(clblue);

FillCircle(320,240,100)

end

end.

3.

program z3;

var k: integer;

begin

write ('Введите число: ');

readln(k);

write((k>99)and(k<1000))

end.

Объяснение:

Условный оператор:

if условие then действие 1 else действие 2

k > 0 - условие проверки числа на положительность (если число больше 0)

k mod 2 = 0 - условие проверки числа на чётность (если число делится на 2 без остатка)

mod - остаток от целочисленного деления

write((k>99)and(k<1000))  - если число трёхзначное, то ответ True, иначе False


Вариант 1Задание 1, Дано целое число. Напишите программу, которая увеличивает эточисло в два раза, е
Вариант 1Задание 1, Дано целое число. Напишите программу, которая увеличивает эточисло в два раза, е
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота