В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kokos22850
kokos22850
08.11.2022 08:14 •  Информатика

Написать на паскале дано n пицц пиццу резать нельзя ! если распределить пиццы поровну среди м друзей , то по скольку пицц получит каждый друг и сколько пицц окажутся не распределенными ? программа получает на вход два натуральных числа n и m , при чем n > m. n не превосходит 10 9 программа должна вывести два числа- сколько пицц достанется каждому другу и сколько пицц останется не распределенными через пробел

Показать ответ
Ответ:
sonasandimirova
sonasandimirova
08.10.2020 22:09

До нельзя просто. div находит целое число от деления, mod — остаток. Путём деления и находим, кто сколько пицц скушает =)

program Pizza2friends;

var N,M:integer;

begin

writeln('Введите количество пицц');
read(N);
writeln('Введите количество друзей');
read(M);

if N > M then
writeln('У каждого друга будет ',N div M,' пицц. Останется ',N mod M,' ничьих пицц.')

else writeln('Пицц должно быть больше, чем друзей');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота