Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
nikitleas
27.03.2023 07:05 •
Информатика
Написать на паскале программу. вывести на экран все трехзначные числа, сумма квадратов цифр которых равна 105. в программе должен быть контроль, является ли число трехзначным.
Показать ответ
Ответ:
Bert18
06.10.2020 09:59
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
for var i:=1 to 9 do
for var j:=0 to 9 do
for var k:=0 to 9 do
if i*i+j*j+k*k=105 then Write(i,j,k,' ');
Writeln
end.
Результат
458 485 548 584 845 854
0,0
(0 оценок)
Популярные вопросы: Информатика
вгььсь
24.10.2022 12:47
Информатика Информатика >...
kopustich1
30.04.2023 02:34
Делать нужно в Python! 4. Запишите программу, которая вычисляет S по формуле: S = (1/2) + (2/2) + (3/2) + (4/2) +…+ (n/2)...
234432343342
07.05.2022 05:14
очень мне В одной из кодировок Unicode каждый символ кодируется 8 битами. Вова написал текст (в нём нет лишних пробелов):СЮ, ЮЛИ, ЁШАФ, ЦОПЁВ, ХЕЛАФИ, ХУФАЦЁЦ, ЗИЗЁМЮШЕ,...
DianaMiss05
02.05.2023 09:58
очень мне Валя шифрует последовательности букв, записывая вместо каждой буквы её код: А -10, Б-100, В-111, Г-000, Д-01, Е-101 Некоторые цепочки можно расшифровать не...
Sashkoo2003
04.02.2023 11:43
¬((x кратно 3)→(x кратно 9)) минимальное значение...
BatsonPlay
18.02.2021 21:35
Плеес это информатика 8 класс. c подробным решением желательно. определите значение переменной c после выполнения следующего фрагмента программы: a : = 60 ; b : = 10;...
dimandra
17.01.2022 03:01
Какой знак сравнения не используется в Python = = # != Укажите правильный вариант вывода переменной а write(a, является четным ); print(a, является четным ) cout writeln(a,...
Mar09
31.03.2022 14:21
с дз по инфе Дано целое число А (оно вводится с клавиатуры), если оно меньше нуля, то умножить его на 2. Если число больше нуля, то разделить на 2. А если равно нулю,...
tolya22112016
10.04.2021 06:12
Что будет выведено после выполнения программы program n_2; var a, b, c: integer, begin a:=61; b:=2; c:=2*a+a-b*a; write(c) end....
Alinasia
21.03.2022 17:26
Переваги та недоліки глобалізації у харчовій промисловості світу...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
for var i:=1 to 9 do
for var j:=0 to 9 do
for var k:=0 to 9 do
if i*i+j*j+k*k=105 then Write(i,j,k,' ');
Writeln
end.
Результат
458 485 548 584 845 854