В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
1Z1D
1Z1D
02.08.2022 02:34 •  Информатика

Написать на языке python напишите программу для решения следующей . ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. найдите самую низкую температуру за время наблюдения. если температура опускалась ниже 15 градусов мороза, выведите yes, иначе выведите no. программа получает на вход количество дней, в течение которых проводилось измерение температуры n (1 ≤ n ≤ 31), затем для каждого дня вводится температура.

Показать ответ
Ответ:
cimuzoro
cimuzoro
07.06.2020 05:19

n = int(input())

cold = False

amin = 100

for i in range(n):

   a = int(input())

   if a < -15:

       cold = True

   if a < amin:

       amin = a

print(amin)

if cold:

   print("YES")

else:

   print("NO")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота