Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
didisa0282
01.06.2021 12:46 •
Информатика
Написать программку на c++ со всеми циклами. дана последовательность с n целых чисел. найти количество элементов этой последовательности, кратных её первому элементу. без использования массивов.
Показать ответ
Ответ:
vovaskorobogat
10.07.2020 23:17
#include <iostream>
int main()
{
int n, first, number, amount = 0;
std::cin >> n;
std::cin >> first;
for(int i = 1; i < n; ++i)
{
std::cin >> number;
if(!(number % first))
amount++;
}
std::cout << amount;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
dashalarkina131
20.04.2021 04:46
Написать программу, вычисляющую значение функции: y = cosx+cos2x+cos3x+…+cos30x...
SlavaPogba
16.10.2020 22:24
Сколько единиц содержится в двоичной записи значения выражения: 8^35+4^7-9?...
diassssssss
08.11.2022 11:08
273∗3-(528+324)÷4= , ! какая правильная последовательность решения? ?...
evasuperpuper123
08.11.2022 11:08
А13. метод познания, выявляющий структуру явления, фиксирующий составные элементы, характер взаимосвязи между ними и предусматривающий разделение целого на составные части...
natakonstantin
08.11.2022 11:08
Втреугольнике tlq, lt равняется lq равняется 13. высота, проведенная из вершины l, равняется 5. найдите qt....
dadfxhg
08.11.2022 11:08
:рассчитайте, сколько коробок товара войдёт в транспортное средство железнодорожный контейнер, при следующих условиях: а) габариты железнодорожного контейнера : длинна 12метров,...
Mynir
08.11.2022 11:08
По проводнику сопротивлением 12 ом в течение 5 с течет ток 3а. за это время в проводнике выделится количество теплоты, равное...
ИльяБлажков
08.11.2022 11:08
Что из перечисленного было положено в основу классификации этих растений на группы? 1 группа: злаки, лилейные, пальмы 2 группа: розоцветные, берёзовые, сложноцветные 1) обитание...
MariaWans07
08.11.2022 11:08
Было бы просто шикарно получить ответ найдите сумму корней уравнения: lg(2x-19) + lgx = lg(3x-20)...
anastasiiauski
08.11.2022 11:08
Какое понятие следует вписать на место пропуска? большая панда микроэволюция персидская кошка 1. искусственный отбор 2. естественный отбор 3. макроэволюция 4. популяционные...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
int main()
{
int n, first, number, amount = 0;
std::cin >> n;
std::cin >> first;
for(int i = 1; i < n; ++i)
{
std::cin >> number;
if(!(number % first))
amount++;
}
std::cout << amount;
return 0;
}