В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Шоце
Шоце
29.10.2022 14:08 •  Информатика

Написать программу (basic) расчёта значения переменной Х по формуле x=ABC(a)+3*√b-8*INT(c)

Показать ответ
Ответ:
Сирена11111
Сирена11111
29.11.2020 19:07
Program p1;

var
  a, b, c, s: real;

begin
  Writeln('Вычислите S поверхности параллелепипеда.');
  Writeln('Введите исходные данные:');
  Write('Длина(см)? '); Readln(a);
  Write('Ширина(см)? '); Readln(b);
  Write('Высота(см)? '); Readln(c);
  s := 2 * (a * b + b * c + c * a);
  Writeln('Площадь поверхности: ', s, ' кв.см.')
end.

Тестовое решение:
Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 300 кв.см.

program p2;
var
  ct,ck,s:real;
  kt,kk:integer;
begin
  Writeln('Вычисление стоимости покупки');
  Writeln('Введите исходные данные:');
  Write('Цена тетради(руб.)? '); Readln(ct);
  Write('Количество тетрадей? '); Readln(kt);
  Write('Цена карандашей(руб.)? '); Readln(ck);
  Write('Количество карандашей? '); Readln(kk);
  s:=ct*kt+ck*kk;
  Writeln('Стоимость покупки: ',s:0:2,' руб.')
end.

Тестовое решение:
Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.
0,0(0 оценок)
Ответ:
Zefirka08
Zefirka08
29.11.2020 19:07
Program p1;

var
  a, b, c, s: real;

begin
  Writeln('Вычислите S поверхности параллелепипеда.');
  Writeln('Введите исходные данные:');
  Write('Длина(см)? '); Readln(a);
  Write('Ширина(см)? '); Readln(b);
  Write('Высота(см)? '); Readln(c);
  s := 2 * (a * b + b * c + c * a);
  Writeln('Площадь поверхности: ', s, ' кв.см.')
end.

Тестовое решение:
Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 300 кв.см.

program p2;
var
  ct,ck,s:real;
  kt,kk:integer;
begin
  Writeln('Вычисление стоимости покупки');
  Writeln('Введите исходные данные:');
  Write('Цена тетради(руб.)? '); Readln(ct);
  Write('Количество тетрадей? '); Readln(kt);
  Write('Цена карандашей(руб.)? '); Readln(ck);
  Write('Количество карандашей? '); Readln(kk);
  s:=ct*kt+ck*kk;
  Writeln('Стоимость покупки: ',s:0:2,' руб.')
end.

Тестовое решение:
Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота