В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
polinamalina2004
polinamalina2004
20.10.2022 09:34 •  Информатика

Написать программу: Дано целое число. Если оно неотрицательное, то извлечь из него квадратный корень, в противном случае возвести в квадрат.

Показать ответ
Ответ:
Zaminaej
Zaminaej
09.08.2020 22:56

program qq;

var i:real;

Begin

 read(i);

 if(i < 0) then

 begin

   i:= sqr(i);

 end

 else

 begin

   i:= sqrt(i)

 end;

write(i:2:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота